CHAPTER IV

IMPLEMENTATION ON C6711 DSK

4.1 Introduction to C6711 DSK

4.1.1 DSK Testing

This example is ? ho begin to use CCS and DSK

board. The examples willidlusttate son _\-.\L es of software and hardware.
Through this chapter, Usefs ¢ GCOme ‘:%\ sing CCS to control the DSK.

“v,\\
This thesis is an impgufé / \ m sing the CCS and DSK by
giving three main exan;
knowled dergfad
owliedage 1n undergra .ﬂf

/Y \\
. I
The DSK testing % A

co L ion of correct operation and

\ understanding towards basic

installation. We have to lahch/CES from pn on the desktop. After that, we have

to select GEL from menu bar,_ .‘_‘_::-.: , hec and click on Quick Test (figure 69).

The following messag 270

C 1S tNCI AISPIayeQa as SEen 1n 1our o [

E Y )

This assumesﬂat the first three switches, LﬂR SW1, USER _SW2, and
USER_SW3, ar all in fxﬁl ON) positién! Change the switches to (110x)2 so that

the first two s uﬂg ﬂmim ’]in\ind the fourth switch is

not used

Repeat the procedure to select GEL = check DSK = Quick Test and verify
that the value of the switches is now 3 (figure 70). Moreover, you can set the value of
the first three user switches from 0 to 7. Within your program you can then direct the

execution of your code based on these eight values. Note that the Quick Test cycles

the LEDs three times.
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A confidence test program example is included with the DSK to test and

verify proper operation of the major components of the DSK, such as interrupts

LEDs, SDRAM, DAM, serial ports and timers.

b

3.1C6x11 DSK (Texas Insiruments)iCPU_T;- C6741. - CodeComposer studio DSK.... {=]8]K]
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Figure 70 Quick Testing of USER_SW1, USER_SW?2, and USER _SW3.
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4.2  The Necessary Files

Writing C program is very difficuit for checking some errors in the program.
Especially, debugging of C program in TMS320C6x is also difficult so we need to
write some important support files for reduce the complex problems. There are some
header files (.h) for defining address, function for interrupt, and function prototypes.
Other support files are initialization the DSK files (.c), linker command files (.cmd),

and assembly files (.asm). Next, we will show the detail of each support file.

e (Co6xdsk.h: this file 4& al memory interface, the serial

port, etc. The file ith F1 suppor
e Coxinterrupts.h: the®Coxinterfup i\
which use for enabl€ th / pIoC
e (C6xdskinit.h: thigfile geader ams the function prototypes.

o (Co6xdskinit.c: #his filefcg »»_,3,_: ? u n ised for the example codec

poling (codec_p#ll) gnclude ' ~ cludes functions to initialize the
DSK the codec, thé€ s al'%

\' tains init function for interrupt,

for mr tput signal.
e (C6Xdsk.cmd: this fi ,:_)‘ir';ﬁ. ile, Which is a simple linker command

il o

file. This file divides in0,two [ ?-_ gory, and section. We can set starting
address for ¢adh V1 ' m, if), the first part. Next, we can
set type of p ardr ¥ e second part.

e Vector 11.asmithis file uses to select interrupt INT11, a branch instruction to

the interrupt servicessoutine (ISR) cgint11 located in the C program, which we

e b %W@W gIN3
. ﬁ%ﬁﬂ@ﬂ%%ﬁ‘ﬂﬂﬂ?ﬁ d

This example is just simple program for generating sine table 8 points. The
benefit of this program is shown some feature of CCS for editing, building a project,

accessing the code generation tools, and running a program on the C6711 processor.
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The sin8_intr program focus on some of using CCS tools, it is useful to
understand the program. This program uses some useful functions. They are necessary

functions for implementing in real-time system.

1. comm_intr function is called that is located in the communication support
file c6xdskinit.c. It initializes the DSK, the AD535 codec onboard the
DSK, and the two mulitichannel buffered serial ports (McBSP) on the
C6711 processor.

2. c_intll is a command proceeds to interrupt service routine

(ISR), which has adg i the file vectors_11.asm.
3. output_sampl
c6xdskinit.c.

buffer.

communication support file

his*funCiton is call d 't output the first data value in the

The state while creatmg an infinite loop to

= 1/Fs = 1/8000 = 0.125
\* ate a sinusoidal signal within

one period. The period of th putsignat ( 125 ms) = Ims.

wait for an interrupt,

ms. It means that eight d

Following, a“step ‘step approact rom starting a project until
showing the plott' i CS an : 1:',,[ the real scope is to be

demonstrated. E ﬂ
1 C“’“ﬂ Tﬂ‘ﬁl? NYNTNYINT

bﬂmm;ﬂ PHIFOLMIh (115}

1. To create the project files sin8 intr. Select project = New Type
sin8_intr for project name as show in figure 4.3a. This project file is save
sin8_intr (c:\ti\myprojects). The sin8 _intr. pjt file stores project
information on build options, source filenames, and dependencies.

2. To add files to project. Select project > Add files to project. Look in

sin8_intr, Files of type C source files and open the files that we want to
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add to our project such as file sin8_intr.c, vectors_11.asm, c6xdsk.cmd,
and rts6701.1ib (c:\ti\c6000\cgtools\lib) etc.

3. The GEL file dsk6211 _6711.gel is added automatically when we create
the project. It initializes the DSK.

4. Note that there are no “include files” yet. Select Project > Scan All
Dependencies. This adds the header files: c67xdsk.h, c6xdskinit.h,

coxinterrupts.h, and c6x.h.

' -'ltﬁ.l;l o 2 et
W.mwn-

= 2 tnelude
Bonr
B fadid
&) chudsbnith
&) churverct:
= ;_I Leoranes
2] AsE701 16
< oj Souce

ﬂ creating project; (b) project

ﬂuaqwﬂﬂ%WHwni

4.3.2 Code Generatlon and Opfions

ARIAINIUUNIINGA Y

In thlS%CCthH, we will describe about various options, which are associated with the

Figure 71. CCS Prﬂct View window for sin8_intr:

code generation tools: C compiler and linker to build a project.
Compiler Option

Select Project > Build Options. We will see a CCS window Build Options for

compiler in figure 72. Select the following for the compiler option: (a) Basic (for
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Category), (b) Speed most critical (for Target Version), (c) Full Symbolic Debug (for
Generate Debug Info), (d) Speed most critical (for Opt Speed vs. size), and (¢) None
(for Opt Level and Program Level Opt). The resulting compiler option is

-ng

The —k option is keep the assembly source file sin8_intr.am. The —g option is

, useful during the debugging process and

to enable symbolic debugging informatior
used in conjunction with the option — ist the C source file with the assembly
source file sin8_intr.asm z“optien”disables many code optimizations
to facilitate the debugging"pre

Select “Default” f \ -point implementation. The

C6711 based DSK carti us a ating-p cessing.

If No Debug is
(for Opt Level), the Compi

ifo), and —o03: File is selected

anged to

-ks -03

The —o03 op -_"'o*r_..—_ imization for performance or

execution speed. ForEow ne Tij er is debugging). Use the

compller option —gks (V\‘e can type it dlre&y in the complier command window).

o B AN TN TP
“gmanIaiumIng s

Cllck on linker (from CCS Build Options) and select Absolute Executable (for
Output Module), sin8_intr.out (for Output Filename), and Run-time Autoinitialization
(for Autoinit Model). The output filename defaults to the name of the .pjr filename.
The linker option should be displayed as in figure 72(b).

- g—c—o “sin8_intr.out” -x
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The —c option is used to initialize variables at run time, and the —o options is to

name the liked executable output file sin8_intr.out. Press OK.

Note that we can choose to store the executable file within a subfolder

“Debug” especially during the debugging stage of a project.

Again, these various options can be typed directly within the appropriate

command windows.

tions: (z mpiﬁ'; (b) linker.

s GBI N SWEINN'S
RTESHImMTINgNa Y

1. Build this project as sin8_intr. Select Project > Rebuild All. Or press the toolbar
with the three down arrows. This compiles and assembly all the C files using c/6x
and assembles the assembly files vectors_11.asm using asm6x. The resulting
object files are then linked with the run-time library support file rts6701.1ib using
Ink6x. This creates an executable file sin8_intr.out that can be loaded into the
C6711 processor and run. Note that the commands for compiling, assembling, and

linking are performed with the Build Option. A log file cc_build_Debug.log is
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created that shows the files that are compiled and assembled, along with the

compiler options selected. It also lists the support functions that are used. Figure

73 shows several windows within CCS from the project sin8_intr.

2. Select File > Load Program in order to load sin8_intr.out by clicking on it (CCS

includes an option to load the program automatically after a build). It should be in

the project sin8_intr folder. Select Debug = Run, or use the toolbar with the

should hear a tone.

“running man”. Connect a speaker t} the OUT connector (J6) on the DSK. We

wed e
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is f= Fs / (number of points) =

8 kHz / 8 = 1 kHz. Connect the output of the DSK to

an oscilloscope to verify a 1 kHz sinusoidal signal with amplitude of approximately

0.85V p-p (peak to peak).
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Pletting with CCS

In this section, we investigate changing some commands to the sin8_intr for

plotting the sinusoidal wave on CCS.

The output buffer is being updated continuously every 256 points (we can

readily change the buffer size). Use CCS to plot the current output data stored in the

buffer out_buffer.
qu

2. Change the Graph Prope / / \ the-op tions in figure 74(a) are selected
for a time-domain plg ( ul d \ en appropriate). The starting

1. Select View = Graph

address of the oufput bfif - th r options can be left as default.

Figure 75 shows#0t . o ~ omain plots of 1 kHz sine

wave.

& Graph Properly Dialog X = GraphProperty Dialog @
[Display Tupe Single Time = = = - =) jay Typé FFT Magnitude =
Graph Title Graphical Display— Sph Titde Graphical Display !
Start Address otA_buffet ..-" :? '_‘ul i! 1 :_.- gol Type Real
Acquisition Bulfer Size - e o
Index Increment 1 1
Display Data Size 256
DSP Data Type 8
Q-value Rectangle
Sampling Rate (Hz) 3 andHold off
Plot D ata From g O 8 Type 16-bit signed integer
Left-shifted Data Display :“ s Q-value I} o
Autoscale D n I Sampling Rate 8000
DC Value Plot Data From Left to Right
Axes Display I Left-shifted D ata Display ch
Time Display | Autoscale
Status Bar
Magnitude =
Data Plot St e Status Bar Display
Grid Style Zero Line Magnitude Display Scale Lneel
Cursor Mode Data Cursor | D at Style Lne
| Giid -r...
CRAMIAE °%’ﬂ£ il
d | Heo J
(a) (b)

Figure 74 CCS Graph Property Dialog for sin8_intr _plot
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4.4 i 4 Rite ; 13se Lock Loop (PLL) on Single
sk :

' iver, which is contained

in this thesis. In orﬂr ary understanding on the

communication system he experiment will be spited into a number of experiments

h as bi hr (
;::u re21’576; genFT ﬂ gﬁ wg wwm ﬂ ?nc onization (see in
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bit [ tion = Demodulation [~
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Figure 76 BPSK transmitter and receiver.
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BIT INPUT: We can use either constant 10-bit digit or a bit stream output from PN

bit generator as an input to the BPSK modulation.

TRANSMITTER PART: BPSK is a digital modulation technique that separates bits
by shifting the carrier 180 degrees. A carrier frequency signal is chosen in order to be
known by both the transmitter and the receiver. Each bit is encoded as a phase shift in
the carrier at some predetermined period. When bit 0 is sent, the carrier is transmitted

with no phase shift, and bit 1 is sent, the carrier is phase-shifted by 180 degrees.

y ""n,
b S

RECEIVER PART: phase'iog \__: : ceiver. The receiver must be able

to lock onto the phase o al 1 o"distinguish between 1s and Os.

To determine the phas

in orde
o0 maximum of the correlation
coefficient is calculated het® / / “\\k\\:\\

“and a sinusoid offset by a

-fricic \\\ . 0 sinusoids is given by
y \ "h I

phase estimate. The cofrelz#

(10)

es

The received sine wave ASE . » and an estimate of the phase is
carrier

@...- The correlation koefficient has a maximum  valuk Jwaen o and @, are

equal.

To dete M}J ﬁ ﬁ ﬂhi‘ﬁeéj ifi itial estimate of ¢,,, .
For every pen@ ngls rEIV 1 w1th a sine wave that
has a phase slightly larger and slight smzﬁ yj 3? Ej ﬁelﬁ( values for the
correlati ﬂg m 1] ﬁhe difference

between these two values gives an approximation of the derivative of the correlation

coefficient. Using the difference between the correlation coefficients at )

est

+¢ and

., — € as an estimate of the derivative, a new value for ¢

est

is calculated using

¢esl = ¢CSI + (Y+I.‘ - Y—C) (1 1)
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Where
2x
Y, = [sint-0+4,,,,) sint-o+¢,, +¢) (12)
0
2
Y, = [sin¢t-0+4,,,)sin¢-o+¢,, - &) (13)
0
This process is repeated €vi ¢ & lillperiod of the incoming sine wave is
received. Eventually, ¢, mwadd ¢, wi eqlialand the derivative estimated by the
-— = - V - )
difference in the correlaiion™coetfici £ andwg,, —c will be 0. When this
occurs, the receiver is@0rsid /
The result of BRSK #fadsiittcr and , with, Phase Lock Loop (PLL) on

single board is shown in fig

O Ty p———

(0.012375, 8182) =

._.i
L

7 Un AwoScale |
¥

AULINENINYINS
ARIANTUNIINGIAE
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4.5  Phase Lock

This phase lock }p g 1mplementat10n consists of two DSKs. The first one

generates a S(H ﬁ? m ﬁ' a constant frequency
which is outpu %9 codec. Su sequently the output signal 1s sent mto the second DSK

TN RTENTTS HvrTIneIas

The sine wave is generated from first DSK which connects to scope as shown

in figure 78.
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Next, we meas geiv il ‘.“‘0 \.

CS from first DSK in figure

79(a). This plot is obtain SUSiNG phiBuf Bs the starting address, with 500
. . Mf 2 A\

points as the acquisition and'disp play-size;; it ﬂoat. In the figure 79(b) shows

a CCS plot of the PLL output b *“;: es only one period of the sine wave.
To use a starting ad dress syml d display size of 16, and a 16-

bit signed integer. y_

-.;amaﬂﬂimu

0 0.0156 00312 3.3¢-4 67e-d  Gded
(0.0155625, 5.780z Time [ln [AuoScae | 437504, 410 [Time Lin (Auto Scake

(@) (b)

Figure 79 CCS plot of a PLL demodulator: (a) output showing eight different

amplitudes; (b) output buffer that receives only one period.



61

We measure the signal on both of DSKs for showing the sine waveform to
scope. In the figure 80, there are sine waveform generated from first DSK on channel

1 and receiver sine waveform second DSK on channel 2.

1

i e S R S el 9

:20.0mv
. 80.0mv

: 2.00ms
: 3.07ms

! : . ; : - . : : Ch1 Freq
: N T O R IR T R . A 1 I [ VR [ T /. & 5S02.0H2

- Ch2 Freq
T e, T ) S)ishe

ChIRRKD
Figure 80 Sine 500Hz ou el 1 is output from first DSK
econd DSK

4.6  Phase Shift Keying lation Implementation

= = o

Phase shift kﬂ‘n , ar ‘gh itting and receiving digital
i

p

signals in which the ‘aSC of a transmitted signal is varied to convey information.
£=%

Several sche it | e’T ﬁone ‘being binary PSK
(BPSK), usirﬁvﬂxgj ﬁaﬂnﬁﬁ 1ﬁﬂf theﬂasc of the wave is (r, then
the siaalﬁw]i ; ?Ti : SE@ &Tﬂnj 1 (i = reverses), the
signal state is higﬁ&ase momHﬁore comI!jgsl:ms ﬁ employ four or

eight-wave phases, allowing binary data to be transmitted at a faster rate per phase
change. In four-phase modulation, the possible phase angles are O, +90", -90", and
1807; each phase shift can represent two bits per symbol. In eight-phase modulation,

the possible phase angles are O, +45°, -45°, 907, -90r, +135°, -135", and 180"; each phase

shift can represent 4 bits per symbol.
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4.6.1 Binary Phase Shift Keying

A single data channel modulates the carrier. A single bit transition, 1 to 0 or 0

to 1, causes a 180" phase shift in the carrier (figure 81). Thus, the carrier is modulated

by the data. Detection of a BPSK signal uses the following: (1) a squarer that yields a

DC component and a component at 2f ; (2) a bandpass filter to extract the f,

component; (3) a frequency divider, the output of which is multiplied by the input.

The result is lowpass filtered to yield a , / signal.

Tek PreVu

i A 40.0mv
1@: 30.0mv
A 504ps
1&: 760us

Chi freq
1.984kHz

L ' el |
SOOmMVS 77 000V
- e

merww SIEPTT =
s‘i“ﬁ?‘faﬁ‘ﬁ‘ﬁfﬁiﬁmfawmaa

Quadrature phase shift keying (QPSK) is a modulation scheme in which the
phase is modulated while the frequency and the amplitude are kept fixed. There are

four phases, each of which is separated by 90" (figure 82). These phases are

sometimes referred to as states and are represented by a pair of bits. Each pair is
represented by a particular waveform, called a symbol, to be sent across the channel

after modulating the carrier. The receiver demodulates the signal and look at the
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recovered symbol for each possible combination of data bits in a pair, QPSK creates
four different symbols, one for each pair, by changing an in-phase (I) and a quadrature

(Q) gain.

The QPSK transmitter system uses both sine and cosine at the carrier
frequency to transmit two separate massage signals, sI[n] and sQ[n], referred to as the
in-phase and quadrature signals, respectively. Both the in-phase and quadrature
signals can be recovered, allowing transmission with twice the amount of signal

information at the same carrier.

—

Tek Prevu |
B : 14 14> 40.0mv
@: 20.0mv

fe 2o g g - [l X 5 oo A Al S92us
: : . \ ' : ' @:  64.0us

i ¢ Ch1l Freq
g B ., F. \ . . 2.520kH2
Low signal
amplitude

4 i \ -+ : ;- beder ¢

Al

oy \:..“

_ © 88%
® 500 0.00 V

Figure QPSK modulator output obtained with a cope.

G UEANININT
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which conveys the analog signal through a codec to second DSK. The second DSK is
set to be receiver which demodulates some information from carrier waveform. We

will give detail about the implementation below.

An input sample is obtained and stored in a memory location, which contains
16 bits. Depending on the type of PSK (two-level or four-level), appropriate masking

is used. For BPSK, an input value is segmented into sixteen 1-bit components; for
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QPSK, it is fractioned into 8 dibits. This is achieved by masking the input with the
appropriate values, 0x0001, and 0x0003, respectively. In order to obtain the next

segment to be processed, the previous input data is shifted once for BPSK or twice for
QPSK.

Following the extraction of segments, values are assigned to sinusoids with

corresponding phases. In BPSK, there are only two phases: 0" and 180" for bits 0 and

1, respectively. However, for QPSK, need four phases (07, 90, 180", and 270°)

corresponding to 00, 01, 11, ¢ 83. This mapping is used in

‘~.. "\
accordance with gray encodine. T error caused by interference
A

during the transmission of (he al by maximizing the distance between symbols
with most different bits g / ’ 7 ich, input sample is represented
with 16 bits. Every sampiéd ¢ / \\N\ BPSK, and 8 segments for
QPSK. Since each symhal isf'ty . \ oid generated digitally by four
points, an input sampf€ isfacgdui p \ put samples for BPSK and

QPSK, respectively.

0 -
-1
0 250
1
Or Phase = 90, Encading = 01 .
1 |JJ!
N'e|J¢ 2 Al P3P 40 45
AT T ¢ -
Ph‘gse= 80, Encoding = 11 e
- .
- . e 181 L,
q w 0 0d 8 25 E
1 L L L} T -\ »
q /
Of Pka\se 270}cud|ng— 10 .
1 /1 1
0 5 10 20 40 45

Figure 83 sinusoids with four phases (0, 90, 180, and 270")
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At the PSK receiver, each sinusoid is mapped into the corresponding symbols
composed of 1 bit for BPSK or 2 bits for QPSK. The extracted symbols are then
aligned in the newly constructed 16-bit value by appropriate left shifts. The sample is
then sent to the codec, and the original waveform is regenerated (see in figure 86 and
figure 87).

Transmitting from one DSK and receiving from another DSK involves
synchronization issue that requires s

(using a PLL).

bol clock recovery and adaptive equalizer

Te -
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